Why the MinimOSD won't connect to the APM?

This is most likely due to outdated firmware that does not support the current MAVLink 1.0 standard used by ArduPlane and ArduCopter. Upgrade your MinimOSD firmware to Version 1.9 or above, which you can find here. Firmware upgrading instructions are here

 

 

Live Chat

Available hours: 8am - 5pm PST

Email

Email our team for support

Hardware Services

Find an Authorized Service Center